1. #1
    Forum Member
    sq51kmg365's Avatar
    Join Date
    Sep 2007
    Location
    Wisconsin
    Posts
    111

    Question light tower issue

    My dept has a 2005 Pierce Enforcer. It has 2 light masts up by the pump panel. Ever since we got the truck we can never get the light towers to go all the way down after we extend them. One side is usually at least 6" higher than the other side. I tried to take them apart and loosen the clamps on the top but that did not work either, even sprayed WD-40 down the shaft-no change. Anyone have this issue? And did it get resolved?

  2. #2
    MembersZone Subscriber

    Join Date
    Sep 2006
    Location
    Kennett Square, PA USA
    Posts
    320

    Default

    Is it possibly binding on the wire?

  3. #3
    Forum Member
    rschultzjr's Avatar
    Join Date
    Dec 2005
    Posts
    105

    Default

    If they are the kind I think you are talking about, we had a similar problem. Inside the tube there is a coiled power cord. We had to spin the light around and around to tighten the cord and then the light would sit down properly. We had to look from below to see which way to spin the light. Hope this may help.

  4. #4
    Forum Member
    sq51kmg365's Avatar
    Join Date
    Sep 2007
    Location
    Wisconsin
    Posts
    111

    Default

    I'll try and see if i can see how the wire is in the tube. I hope that is the issue, because we have the same thing on our other trucks and we have no problem with those. Thanks!!

  5. #5
    Forum Member

    Join Date
    May 2006
    Posts
    84

    Default

    If they are the Wilburt tower with 4 heads, like on our engines, we had a problem with the one mfg in 05. The Wilburt tech came out and upgraded the electronics in the controller and some airline issues in the mast. It was warranty work when this was done. We had problems of not stowing completely, shutting off sporadically, and some other minor issues but no problems since the repair.

  6. #6
    Forum Member

    Join Date
    Oct 2007
    Posts
    17

    Default

    If it's a Wilburt, I've had good experiences with their tech support folks. Give them a call and they'll walk you through the diagnostics.
    "If it's stupid but it works... It ain't stupid."
    Murphy's law of combat

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Light Tower
    By SWIPP in forum Apparatus Innovation
    Replies: 13
    Last Post: 01-16-2006, 03:20 PM
  2. Wilbur Light Tower Problem
    By Tom014 in forum The Engineer
    Replies: 10
    Last Post: 06-06-2003, 09:03 AM
  3. Super-Vac Light Tower Parts
    By northshorefire2 in forum Apparatus Innovation
    Replies: 0
    Last Post: 03-15-2001, 12:55 PM
  4. Wil-Burt Light tower problems
    By JohnM in forum The Engineer
    Replies: 5
    Last Post: 10-31-2000, 06:20 PM
  5. Light Tower on New Apparatus
    By Capt2405 in forum Apparatus Innovation
    Replies: 4
    Last Post: 11-10-1999, 02:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in

Click here to log in or register